Aug 24, 2019  
2018-2019 Undergraduate Catalog 
    
2018-2019 Undergraduate Catalog [ARCHIVED CATALOG]

[Add to Portfolio]

IT 370 - The Command Line Interface and Cybersecurity


Description:
This course provides an introduction to the cybersecurity script programming paradigm, and introduces and compares a range of security scripting languages used for Linux and Web-based applications. Course will be offered every year. Course will not have an established scheduling pattern.

Prerequisites:
Prerequisites: IT 238 and IT 351.

Credits: (4)

Learner Outcomes:
Upon successful completion of this course, the student will be able to:

  • Utilize looping and selection statements.
  • Utilize truth tables in the evaluation of conditions.
  • Construct a script that will help secure a system.
  • Evaluate a script for security vulnerabilities.
Learner Outcomes Approval Date:
2/15/18



[Add to Portfolio]